Modber Сообщество
профессионалов по 1С

Внешний отчет, вывод результата запроса
  
Сообщений: 1

0
Я учусь писать, не пойму как тут вывести результат, подскажите пожалуйста [code=1C] &НаКлиенте Процедура Команда1(Команда) ТабДок=СформироватьЭтотГребанныйОтчет(); ТабДок.Показать(); КонецПроцедуры &НаСервере Функция ВыполнениеЗапросаНаСервере() Макет=ПолучитьМакетНаСервере(); ТабДок=новый ТабличныйДокумент; ОблЗаголовок=макет.получитьОбласть("Заголовок"); ОблПарам=макет.получитьобласть("Параметры"); Запрос = Новый Запрос(); Запрос.Текст = "ВЫБРАТЬ | КОЛИЧЕСТВО(РАЗЛИЧНЫЕ КонтДатыПроверкиЛояльности.Контрагент) КАК Контрагент, | КонтДатыПроверкиЛояльности.Лоялен КАК Лоялен, | КонтДатыПроверкиЛояльности.Контрагент.ЮридическоеФизическоеЛицо КАК ЮрФиз, | NULL КАК Лояльныеконтрагенты |ИЗ | РегистрСведений.КонтДатыПроверкиЛояльности КАК КонтДатыПроверкиЛояльности |ГДЕ | КонтДатыПроверкиЛояльности.Период МЕЖДУ &НачалоПериода И &КонецПериода | |СГРУППИРОВАТЬ ПО | КонтДатыПроверкиЛояльности.Контрагент.ЮридическоеФизическоеЛицо, | КонтДатыПроверкиЛояльности.Лоялен"; Запрос.УстановитьПараметр("НачалоПериода",НачалоПериода); Запрос.УстановитьПараметр("КонецПериода",ЭтотОбъект.КонецПериода); ЗапросЛояльные=новый запрос; ЗапросЛояльные.Текст="ВЫБРАТЬ РАЗЛИЧНЫЕ | КонтДатыПроверкиЛояльности.Контрагент |ИЗ | РегистрСведений.КонтДатыПроверкиЛояльности КАК КонтДатыПроверкиЛояльности |ГДЕ | КонтДатыПроверкиЛояльности.Период МЕЖДУ &НачалоПериода И &КонецПериода | И КонтДатыПроверкиЛояльности.Лоялен = ИСТИНА"; ЗапросЛояльные.УстановитьПараметр("НачалоПериода",ЭтотОбъект.НачалоПериода); ЗапросЛояльные.УстановитьПараметр("КонецПериода",ЭтотОбъект.КонецПериода); ВыборкаОбщая=Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам); ВыборкаЛояльные=ЗапросЛояльные.Выполнить().Выбрать(); ТабДок.Вывести(ОблЗаголовок); Пока ВыборкаОбщая.Следующий() цикл //Если ВыборкаОбщая.ЮрФиз=Перечисления.ЮридическоеФизическоеЛицо.ФизическоеЛицо тогда ОблПарам.Параметры.КК=ВыборкаОбщая.Контрагент; ОблПарам.Параметры.Лояльность=ВыборкаОбщая.Лоялен; ОблПарам.Параметры.Статус=ВыборкаОбщая.ЮрФиз; ТабДок.Вывести(ОблПарам); КонецЦикла; Пока ВыборкаЛояльные.Следующий() цикл КонецЦикла; Возврат ТабДок; ///////////////////////// КонецФункции &НаСервере Функция ПолучитьМакетНаСервере() ЭтаХрень = РеквизитФормыВЗначение("Отчет"); Макет = ЭтаХрень.ПолучитьМакет("Макет"); Возврат Макет; КонецФункции [/code]
В начало страницы 
Перейти на форум: